In order to allow users of MySQL 5.5 more time to upgrade their database engines, we have recently changed our MySQL 5.5 roadmap to remove several cPanel & WHM upgrade blockers.

If you run MySQL 5.5 on cPanel & WHM version 78, you can upgrade to 86. You cannot upgrade to 88 or 90. If you run 5.5 on cPanel & WHM version 86, you can upgrade to 92.

Even though a cPanel & WHM version may allow you to run MySQL 5.5, that version of MySQL it still end-of-lifed; cPanel, L.L.C. will thus be unable provide support for any technical issues that you have with the database.

We strongly encourage you to upgrade MySQL to a supported version as soon as possible in order to avoid any vulnerabilities or incompatibilities with third-party applications such as WordPress®.

If you run MySQL 5.5, we’d like to hear from you as to why you are still running this out-of-date software and what is preventing you from upgrading to a supported version. Please take our survey about MySQL 5.5 support: https://go.cpanel.net/mysql55forums

As always, if you have any feedback or comments, please let us know. We are here to help in the best ways we can. You’ll find us on Discord, the cPanel forums, and Reddit.

Posted by Surfer Chick